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Session 8: Introduction to QGIS (interface, main functionalities)

Navigating the Interface:

Desktop

(2 Untitled Project — QGIS = (m] X

Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh Processing Help
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Favorites

» % Spatial Bookmarks @
» [6] Home

» [ C\ (Windows)

» [7 D:\ (New Volume)

» E:\ (My Passport)

4 F:\ (FreeAgent GoFlex Drive)

;WO S
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QGIS interface is divided into 6 main areas:

Layers List
Browser Panel
Toolbars

Map canvas
Status bar
Side Toolbar
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Manage Layers Toolbars Map Navigation Toolbars

Add/Edit Virtual Layer
Add PostGIS Layers
Add WMS/WMTS Layer
Add WCS Layer

Add WEFS Layer

New Shapefile Layer

Zoom Full

Zoom to Selection
Zoom to Layer
Zoom Last

Zoom Next

VVCERYLZBG- @BV 002 HRPPRAMGBREDR
Add Vector Layer e Pan Map
Add Raster Layer e Pan Map to Selection
Add Mesh Layer e Zoom In
Add Delimited Text Layer e Zoom Out
Add Spatialite Layer e Zoom to Native Resolution

New Map View
New Bookmark
Show Bookmarks

Refresh



N A=A MORU ::: -”:@ HEALTH

ELIMINATION NETWORK Tropical Health Network NS, G E 0 L A B

Attributes Toolbar
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e |dentify Features

e Run Feature Action

e Select Features by area or single click
e Select Features by Value

e Deselect Features from All Layers

e Open Attribute Table

e Open Field Calculator

e Toolbox

e Open statistical summary
e Measure Line

e Show Map Tips

e Text Annotations
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Saving Project Files

(2 *Untitled Project - QGIS = m] X
h Edit View Layer Settings Plugins Vector Raster Database Web Processing Help
e o et @ MARAB%-RBR-V:- 4/BR- >R &
Open... Ctrl+O 3 2 v ﬁj [T]~ @ ‘:» )"E’ }5’ /.“ ;: g‘) p }a e UE H—g Htuh\ e
Open From »
Open Recent »
Close
2 Save Ctrl+S
[ SaveAs... k Ctrl+Shift+S
Save To »
Revert...
Properties... Ctrl+Shift+P
Snapping Options... (@ Choose a QGIS project file X
Import/Export ? 4 ||| « EXERCISE_5.B_QGIS > Data v || | search Data P
I3 New Print Layout... Ctrl+P ;

21 New Report.. Organize v New folder . gz -

%) Layout Manager... & This PC *  Name Date modified Type
Layouts » 8 3D Objects Kampong-Cham 14/06/2018 T:39AM  File folder
Exit QGIS Ctrl+Q [ Desktop

|Z Documents
& Downloads
D Music
v < >
Layers Browser Efename ‘ V|
L Type to locate (Ctrl+K) Read oordinat| 105.050,11.729 % zal | 1:6327 Save as type: |QGZ files (*.qgz) r
A HideFolders  ofres(.ag2) I cameer

e QGIS can save user sessions. (A QGIS file is called a project.)
e Project > Save
e Type in a file name and save your project as a QGZ file (.qgz)

o QGZ file format is a new default format for QGIS. It is a compressed
format with the .qgs file (former default format) embedded in it
together with its associated sqlite database (.qgd) for auxiliary data.
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Browser Tab

Right-click on the Toolbar area to
add Browser or other panels l

() *Untitled Project — QGIS
Project Edit View Layer 3Settings Plugins Vector Raster Database Web Mesh Progessing Help

DR K-8 -0 VRERBELXABS @G Vo -] o

Browser (2) Panel

v / N q?, §§§' 2 'E] v o v Fe ¥ @ o Brewser Panel

Debugging/Development Tooks Panel

Layers B® GPS Information Panel
A TR i
& v M veH Bodensce

<

Layers Panel
Log Messages Panel
Overview Panel
Processing Toolbox Panel
Results Viewer Panel
Spatial Backmark Manager Panel
Statistics Panel
Temporal Controlier Panel
Tile Scale Panel
Undo/Redo Panel

Toolbars
Advanced Digitizing Toolbar

Annotations Toolbar
¥ Attributes Toolbar
Data Source Manager Taolbar

N
& Browser ®

i g

Database Toolbar

| Digitizing Toolbar
! Help Taolbar
Label Toolbar
/| Manage Layers Toolbar
/) Map Nevigatien Taolbar
Mesh Digitizing Toolbar

5.7 Favorites

» [ Spatial Bookmarks
- Drag and drop

> 03 &\ Windows onto canvas
» [ DA (New Volume) ' of| Project Toolbar
Raster Toolbar

» [ EA(My Passport) ¥ Selection Teolbar
» [ 7] FA (FreeAgent GoFlex Drive) Shape Digitising Toolbar
e GeoPackage Snapping Toolbar

. W Vector Toclbar
f Spatialite ! Web Toolbar

el

/| Plugins Toolbar

DOEmA

Zoordate| 47047362441 | icole| nd010as v | @ dagnifer| 100% | tation | 0.0° 2| Virender @Erunknowncrs @

Jo)

Browser From the Manage Layers toolbar or the Browser panel, you
Panel can add shapefiles, databases, WFS, WMS, and several other
types of files




oornen MORU * HEALTH

I ELMIGATION METWORK Tropical Health Network @ GEOLAB

Project Properties

(& *Untitled Project — QGIS
Edit View Llayer Settings Plugins Vector Raster Databasel

New CtrleN |- By~ O -vc-

New from Template

(@ Project Properties

Open.. -0

Open From R Location of the project file; Map color; Map units; Coordinate and bearing display

Open Recent »
Close

I‘ Metadata Allows detailed information about the project to be defined
@ save Ctri+S

3 Save ... Ctrl=Shift+S

Save To »

View Settings Provides means to control the project map canvas

it

— = CRS Helps set the coordinate reference system to use in the project
P B - Shifte

Snapping Options...

mportExport , f"; Tansformations Helps control the layers reprojection settings
i L e |+ | . . o
3 New Brint Layout cul- - Helps control how the new layers will be drawn in the project
) New Report... &  Default Styles
2 Layout Manager... ) . . .
Lovouts ,|@® Helps control functionalities and layer capabilities
cd E Data Sources
Exit QGIS Ctrl+Q i
Ty g reme ES . Used to define 1:n relations and polymorphic relations
p + [ G\ (Windows) B Relations
| Do Lists all variable available at the project’s level
» 03 E\ My Passpory et ists all variable available at the project’s leve
9] | » [ FA (FreeAgent GoFlex Drive)
p Y GeoPack Used to edit Python macros for projects
@ @ GecPockage @ Macros Y proJ
/7 SpatiaLite o
(%} Allows to configure the project in order to publish it online

QGIS Server

oordinate| -52246,-356180 Used to set the temporal range of the project

Project Properties changes the default project setting for the CURRENT QGIS
project.
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Panels and Toolbars

clicking on the toolbar area

Panels and Toolbars: ¥ Panels on top...
e Turn them on and off by e
going to View > Panels or g o b E
Toolbars. T —— -
e Panels provide interactive : Dl onane f
“windows”. Examples: “ ‘ S| b
Layers,GPS Information, - W | e &
and toolbox Aedl - |
e Toolbars are a grouping of ff i e ;»;
tools > “”’" I.;Z_w \
e Panels/Toolbars can also be = = 1= o e B
added/removed by right- N ;'*“
<

...Toolbars
on bottom
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Vector Layer Properties

(Q *Untitled Project — QGIS

4

Layers

561

o Y

D

Browser
OTTO
-‘C » [@] Home
» [ €A\ (Windows)
» 5 DA (Mew Volume)

3 [ [T EA My Passport)
[0] | » [ FA (FreeAgent GoFle

@® & GeoPackage

Project Edit View Layer 3ettings Plugins Vector Raster Databas

DEBERR

v fle TE-RALD
& I —

£ spatiaLite

o | @ rosisis

BH-8--% V

B®

10 Zoom to Layer(s)
Zoom to Selection
2 Show in Qverview
Show Feature Count
=1 Show Labels
Copy Layer
Rename Layer
& Update SOL Layer...
L] Duplicate Layer
[1 Remove Layer...
““ Open Attribute Table
J/ Toggle Editing
Filter...
Change Data Source...

Set Layer Scale Visibility..

Layer CRS »
Export »
Styles »

Add Layer Notes...

EE———

Toggk Zoordinate| -48426,-358303

G Layer Properties —

(Q

0 Information

‘}:\\ Source

¥ symbology

€ Labels

€O Masks

:’ 3D View
Diagrams

E Fields

- Attributes Form
Joins

ﬁ Auxiliary Storage

-

® oy

g/ Rendering

” Temporal
Variables

l‘ Metadata

E Dependencies
Legend

ZT. QGIS Server

B vigiiing

Read-only summary of information and metadata on the current layer

Used to define general settings for the vector layer

Provides a comprehensive tool for rendering and symbolizing vector data

Provides the capabilities to configure smart labeling on vector layers

Helps configure the current layer symbols overlay with other symbol layers or labels

Allows to add a graphic overlay to a vector layer

Enables 3D rendering

Provides information on fields related to the layer

Helps set up the form to display when creating new features

Allows to join a loaded attribute table to a loaded vector layer

Allows to store properties for layers that are not editable

Provides the ability to perform an action based on the attributes of a feature

Helps configure fields to use for feature identification

Allows to set the scale dependent visibility and simplify geometry

Provides option to control the rendering of the layer over time

Lists all the variables available at the layer's level

Provides options to create and edit a metadata report on a layer

Allows to declare data dependencies between layers

Provides advanced settings for the Layers panel and/or the print layout legend

Consists of Description, Attribution, MetadataURL, and LegendUrl sections

Gives access to options that help to ensure the quality of digitized geometries

The (Vector) Layer Properties window provides information about the vector layer

and provides general settings to manage appearance of layer features in the map
(symbology, labeling, diagrams) and interaction with the mouse (actions, map
tips, form design).
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Data Projections

@ *Untitled Project — QGIS
Project Edit View Layer Settings Plugins Vector Roster Databasq
] =) os . B~ P [
ODE 8RR I%El -5 V;
v I/ =
Layers e®
Ueawva-aan
2,
"4 VGH Bodense 4D Zoom to Layer(s)
}'ﬁ Zoom to Selection @ Layer Properties — VGH_Bodensee — Source X
o ©2 Show in Qverview I I
= o ®
} Show Feature Count -
Layer name |VGH_Bodensee
;’3 @ Show Labels Information
“ 3 Data source encoding | UTF-8 -
p Copy Layer H source
e Rename Layer = W Assigned Coordinate Reference System (CRS)
;\) ¥ symbology
& Update SOL Layer... e s -l[®
1384 Lambert L 2
[ Duplicate Layer QX Labels R T 2y the origs Saction of Tatkuras: Kothar: S v
" Remove Layer... e "
= A0 Masks The Processng “Resroject Layer ool shoud be d par
Browser ' Open Attribute Table °.
GRY®O J Toggle Editing Nff 50 Yiew v Geometry
= 5 -
'g3 | [&] Home Filter... , Diagrams Creste Spatial Index | | Update Extents
=\ » [T €\ Windows) Change Data Source... E s
“ |» 5 DA (New Volume) Set Layer Scale Visibility... St !
& [ EA (My Passport) Layer CRS » BB nvsbutesForm
8] | » [ F\ (FreeAgent GoFlex Export » Yoz
— | @ GeoPackage
Styles 4 3
® £ spatilite :" Auscliary Storage
- Add Layer Notes...
SAP HANA
MSsOI ¥ ‘. Display.
Q Type to locate (Cri+K Toggle Zoordinate | -131085,-346206 | 4 Rendeing = :
| Query Buider
8 oonl
L oK Cancel Apply Help.

All vector/raster layers have a projection or CRS. The quickest way to check
projections is to right click on the layer > Properties > Source
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@ *Untitled Project — QGIS
Project Edit View Layer 3ettings Plugins Vector Raster Database Wel
D e MR L
- @,
Layers (@)
« @ TV O30
s mkd srtm - E
7 [l VGH Bodens] - Zoom to Layer(s)
©9 Show in Overview
Copy Layer
Rename Layer
[ Zoom to Native Resolution (100%)
Stretch Using Current Extent
[} Duplicate Layer
[l Remove Layer...
Move to Bottom
T Change Data Source...
LeTte Set Layer Scale Visibility...
- . Layer CRS ’
“. “" Favorites Export R
» Spatial Bookmarks
» [&1) Home Styles !
+ [ €\ Windows) Add Layer Notes...
» 75 04 (ewolame m
» [ E\ (My Passport)
» [ F\ (FreeAgent GoFlex Drive)
@ GeoPackage
£ spatislite
[ v
™ Criek 1legend entriesr Coordinate | -519.2,-315.6
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Read-only summary of information and metadata on the current layer

Displays basic information about the selected raster

J\s\ Source

% symbology

Allows to change to the band and color rendering and raster resampling

A

Allows to set the transparency level of the raster layer

Iﬂ Transparency
Histogram

Allows to view the distribution of the bands or colors in the raster

Allows to set scale dependent visibility and refresh layers at interval

Rendering

&

“ Temporal

Provides option to control the rendering of the layer over time

‘ Pyramids

Allows to build pyramids to improve raster performance

Provides options to create and edit a metadata report on a layer

Provides a list of widgets that can be embedded in the Layers panel

QGIS Server

Consists of Description, Attribution, MetadataURL, and LegendUrl sections

The (Raster) Layer Properties window provides information about the layer as

well as the ability to set pyramids levels, adjust appearance, and view the

histogram.
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Layout Manager

( Untitled Project - QGIS
Edit View Layer Settings Plugins Vector

Ctrl+N '
]
b 2

eCce

| 1) New
New from Template »

Ctrl+0

Open... % Layout Manager = = X

Open From

Open Recent »

) New
Close D Print Layout
i Save Ctrl+S

F2 Save As... Ctrl+Shift+S

Save To »

Show Duplicate Remove Rename

w New from Template

Revert...
Properties... Ctrl+Shift+P
Snapping Options... Empty layout
Import/Export »
Ctri+P

7} New Report... al

B Layout Manager... A

Layouts »

NCOUNTRIES KM WMap_Template\KHM_MOH_Landscape_11052018

I3} New Print Layout...

% Create print layout Title X

=

Enter a unique print layout title
(a title will be automatically generated if left empty)

Exit QGIS Ctrl+Q |

Cancel

The Layout Manager allows you to create a new map layout either from an empty
layout or a template. It can be accessed from the Project menu (Project > Layout
Manager) or in the Print Layout window (Layout > Layout Manager).
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Print Layout

| @ "New o x
| Layout Edit View Items Add Ites Settings
 BRLURDR R eHhEhkhoeo Biee: IIHHR
| PP PRR @O R GE A -
B [ e T e T T T e
19|
| P

‘E ‘: - a | MAP TITLE ; == <Scalebar> h
| £ Legend

B - :’,,l:;w : mMez:nTmE

R - v ] Map 1

R " = —_—
0|

a2 A

i i " EE)
Kk
| f5p 2

L  Update Preview i
I‘E Sale [st47s L=
I;V_E ml 0 1 Map rotation |0.00 ° IS €
| n;§: RS Use project CRS - |[®
| ¥ _: V' Draw map canvas items -
i 1item selected x: 310.903 mm y: 98.3803 mm page: 1 8.7% v =

Print Layout interface: 1. Menu Bar; 2. Toolbar; 3. Map Layout; 4. Items and

Command History; 5. Layout Properties; 6. Item Properties; 7. Guides




wl A PACIFIC MALARIA MO RU .t /‘ H E A L T H

ELIMINATION NETWORK Tropical Health Network ) @ G E 0 L A B

Layout Toolbar Navigation Toolbar
ERLREB Rekkkhoee o0 HD
e Save project e Zoomin
e New layout e Zoom out
e Duplicate layout e Zoom to 100%
e Layout manager e Zoom full
e Add items from template e Refresh view

e Save as template
e Add Pages...

e Print Layout

e Export asimage
e Export as SVG...
e Export as PDF...
e Undo

e Redo
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Print Layout

> Click on the Add Map button then draw a rectangle
for where the Map Canvas will appear.

@ *Print Layout s o X
Layout Edit View [tems Additem Atlas Settings
BERLREB ReRHRhoeo @ ¢ (90 HH
PLLELC BRC LE LB IE]
J.,..P..,.|....F‘?.......,|“?°...|,... 1?0..”..-.Iz?ou.l....F?...u.,.'.Fl?o.., Items = Undo History
@ = Items (=1
p'o_ ® @ ltem
X - u) O = v [ Map1
|
2 |33
L] ‘[; 3
g - Layout | ltemPropertes | Gudes
8- ) O Item Properties 2%
= ept
Lj"d _: w Main Properties =
'-_0'3—: Update Preview
-::6 —E Scale 429806 @
4‘?) - Map rotation | 0.00 © OR =8
A ? u| ! = ®s Use project RS v)®
3 V| Draw map canvas items
¥ = -
1 item selected X: 291.336 mm y: 100,554 mm page: 1 48.7% v |CF
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Map Elements

This area keeps track of changes

Add map elements by clicking on the icons on and allows you to customize map <

the toolbar or in the Add Item menu elements.
Q *New - (=] > %
Layout Edit View lte m htlas  Settings |
BLRDOE & ®Bipkhe B € "PHSHR
o }Tr }ﬂ :: c D, 1G] f—1 7 | ! "'. Ml
J..‘.P‘...l...‘Fq‘..l...ylm-oy..l....]l?o.,.|....F?O...u,,..F?o...x,.,.lm.oj., Items | Undo History
@ 3 ftems B
,}\’ = @ - tem
3 T v = <Picture> b
x 3 MAP TITLE v w= <Scalebar>
3 taguad v 3= Legend
15l gy, 3 90 v T MAP TITLE
R EE ;e v Map 1
3 [T pe—-Y
Q ? ° 0 Wim Layout = ItemProperties = Guides |
:: B i Item Properties B®
T - Map1 .
oo w Main Properties
— 5 L
3 Update Preview
"B =
- Scale 546475 €
“VE N
2l 3 n Map rotation | 0.00 * S
T xs Use project (RS
_: V| Draw map canvas items -
1 item selected x: 310,903 mm y: 98.3803 mm page: 1 48.7% b (5

Once the map has been added, the other map elements can be added. Their
properties, as well as the page properties, can be viewed and modified. The Print
Layout tracks changes in the Undo History window.

Layout Item Properties
e Set the grid spacing and snap e Set the font
tolerance _

e Set scale bar properties

e Export settings )
e Setlegend properties

e Resize layout to content .
e Set map element properties




