:éi APMEN] | 2z Pacitc alara MORU *« HEALTH (¢

’//‘?1‘\
B Elimination Network Tropical Health Network GEOLAB 7 '

Introduction to geospatial data management
and technologies for Health Programs training workshop - Timor Leste

Exercise 2: Using the basic functionalities of GIS software (QGIS)

Navigating the Interface:

@ Untitied Project —QGIS

Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh Processing Help
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QGIS interface is divided into 5 main areas:
1. Main Menu
e Provides access to various QGIS features using a standard hierarchical menu
2. Layers Panel / Browser Panel
e Layers Panel: where you will see the list of different map layers you have added to

your map
e Browser Panel: Lets you easily navigate in your file system and manage your data.
3. Toolbars

e Provides access to most of the same functions as the menus, plus additional tools
for interacting with the map

4. Map View
e Also called Map canvas, this is the “business end” of QGIS — maps are displayed in
this area.

5. Status bar
e Provides you with general information about the map view, and actions processed
or available and offers you tools to manage the map view.
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Saving Project Files

() *Untitled Project — QGIS
Edit View Layer Settings Plugins
' New Ctrl+N

Vector Ras

iy

New from Template >

Open... Ctrl+0

Open From 'le®

Open Recent >

Close 2

—

[ Save As... Ctrl=Shift+S
Save To »
Revert...

/ Properties... Ctrl+Shift+P

Snapping Options...

Import/Export »
& New Print Layout... Ctrl+P
+, New Report...

& Layout Manager...

Layouts >

Models »

Exit QGIS Ctrl+Q

e QGIS can save user sessions. (A QGIS file is called a ‘project’.)
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@ Choose a QGIS project file

T~ <« EXERCISES > EXERCISE_ 4
Organize v New folder
Name
33 Dropbox DATA
8 This PC LoGo

= Windows (C:) |
= New Volume (D:

= My Passport (E)

MAP_TEMPLATE

Search EXERCISE_4 »r

= FreeAgent GoFle

]
(-]

File name:

Save as type: QGZ files (.qgz)

A Hide Folders

Cancel

Save

e From the main menu, click Project > Save

e Type in afile name and save your project as a QGZ file (.qgz)

o QGZ file format is the new default format for QGIS. It is a compressed
format with the .qgs file (former default format) embedded in it
together with its associated sqlite database (.qgd) for auxiliary data.
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Manage Layers Toolbar

VVIREBEYARBR- @K " VL

Add Vector Layer

Add Raster Layer

Add Mesh Layer

Add Delimited Text Layer

Add Spatialite Layer
Add/Edit Virtual Layer

Add PostGIS Layers

Add WMS/WMTS Layer

Add WCS Layer

Add WEFS Layer

Add Layer from STAC Catalog

New Shapefile Layer

Attributes Toolbar

e

% éi}% E = mmv g Q«v
Identify Features
Open Field Calculator

Toolbox

Show Statistical Summary

Open Attribute Table

Measure Line

Show Map Tips

MORU :: HEALTH @

BN
Tropical Health Network GEOLAB'~ Q%

Map Navigation Toolbar

QR ALRPP  RLEBSGED

Pan Map

Pan Map to Selection
Zoom In

Zoom Out

Zoom Full

Zoom to Selection

Zoom to Layer

Zoom to Native Resolution

Zoom Last

Zoom Next

New Map View

New 3D Map View

New Spatial Bookmark
Show Spatial Bookmarks
Temporal Control Panel

Refresh
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Browser Tab
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Project  Edit  View Layer Settings
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onto Canvas
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Right Click in Toolbar area to add browser
aasa0ms OF Other panels to the Desktop

Raster Databas= Web  Processing Help

E Browser | Layers |

b Browser Tab
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# wolbox
Advanced Digitzing
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GPS Information
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Spatisl Bookmarks
Statistics

Tile scale
Unao/Redo
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From the Manage Layers Toolbar and the Browser Panel you
can add Shapefiles, Databases, WFS, WMS, and several
other types of files.




‘-"\-‘ APM E N | Asia Pacific Malaria
-‘e'- Elimination Network

Project Properties

Q *Untitled Project — QGIS
Edit View Layer Settings Plugins Vector Raster Dg

| New Ctrl+N
New from Template 4
Open... Ctrl+0
Open From »
Open Recent »
Close
E] Save Ctrl+S
[ Save As.. Ctrl+Shift+S
Save To »
Revert...
Snapping Options...
Import/Export »
) New Print Layout... Ctrl+P

+4 New Report...

% Layout Manager...
Layouts »
Models »
Exit QGIS Ctrl+Q
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Q Project Properties — General

View Settings

CRS

a3

o

{

B &

Styles

Colors

Data Sources

Relations

Variables

C‘@ Macros

=T QGIS Server

” Temporal

l Elevation
E-

¢  Sensors

Transformations

&——— Project file name; Project home; Map Measurements

Allows detailed metadata to be defined

Provides means to control the project map canvas

Helps set the coordinate reference system of the project
Helps control the layers reprojection settings

Allows to configure symbols and colors

Allows to choose the color model of the project
Allows to configure the editing behavior & layer capabilities
Used to define relations between layers

Allows to manage project-level variables

Used to edit Python macros

Allows to configure project in order to publish it online
Used to set the temporal range of the project

Helps configure default settings for the terrain and elevation

Used to configure sensors and toggle their connection status

Project Properties allows to change the default settings for the CURRENT QGIS project.
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Panels and Toolbars

Turn them on and off by going
to View > Panels or Toolbars —
Panels provide interactive
“windows”. Examples: Layers,
Browser, GPS Information
Toolbars are a grouping of
tools

Panels/Toolbars can also be
added/removed by right-
clicking on the toolbar area
then checking/unchecking the
desired panel or toolbar

Progessing Help
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@ *Untitled Project — QGIS
Project _Edit

Layer Settings Plugins Vector Raster

Ditabsse  Web Mesh wmm.g H,w,,

= ) New Map View CerieM >
D 1 30 MapViews »r B @ % %
] 50 panap LN1S) :J
B Pan Map to Selection
o & w g F Zoomin CerloAltes
5 Zoom Out CtrleAltes
@, \dentify Features CrteShifts]
Measure ,
= Statistical Summary
Elevation Profile
3 Zoom Full CtrivShiftaF
Cerle)
m to Native Resolution (100%
g} Zoom Last
Zoom Next
Decorstions ,
Preview Mode ,
& Show Map Tips
1. New Spatial Bookmark... Ceri+B
¥/ Show Spatial Backmarks Ctrl+Shift+ B
¥ Show Spatial Bookmark Manager
£ Refresh ]
Layer Visibility »
Toolbars »| V| Browser Panel
Toggle Full Scrgen Mode il Browser (2) Panel
Toggle Panel Visiblity CerleTab Debugging/Development Tools Panel
Teggle Map Only Crl-Shift=Teb GPS Information Panel
Layer Order Panel
Layer Styling Panel
V! Layers Panel
Log Messages Panel
OvenviewPanel
Processing Toolbex Panel
Results Viewer Panel
@ Search QMS Panel
Spatial Bookmark Manager Panel
Statistics Panel
Temporal Controller Panel
— — Tile Scale Panel
Undo/Redo Panel
= Vertex Editor Panel
Panels =
Advanced Digitizing Panel
Browser (2) Panel
Browser Panel
Debugging/Development Tools Panel
GPS Information Panel
Layer Order Panel
Layer Styling Panel
Layers Panel
Log Messages Panel - Panels
Overview Panel
Processing Toolbox Panel on top
Resutts Viewer Panel
@ Search QMS Panel
Spatial Bookmark Manager Panel
Statistics Panel
Temporal Cantroller Panel
Tile Secale Panel
Undo/Redo Panel
Vertex Editor Panel -
Toolbars =
Advanced Digitizing Toolbar
Annotations Toolbar
Attributes Toolbar
Data Source Manager Toolbar
Database Toolbar
Digitizing Toolbar
Help Toolbar
Label Toolbar
Manage Layers Toolbar Toolbars
Map Navigation Toolbar = at the
Mesh Digitizing Toolbar
Plugins Toolbar bottom
Project Toolbar
Raster Toolbar
Selection Toolbar
Shape Digitizing Toolbar
Snapping Toolbar
Vector Toolbar
Web Toolbar -

©
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(3 *Untitled Project — QGIS
Project Edit View Layer Plugins

NEBRRY &N-8-6-
go oL RPpP

Settings Vector Raster

Layers []E3)
« @ ® TVE-BAD
TOLKIEN BRG

40 Zoom to Layer(s)
Zoom to Selection
U?J Show in Qverview
Show Feature Count
w0 Show Labels
Copy Layer
Rename Layer
[ Duplicate Layer
[C1 Remove Layer...
~ Open Attribute Table
J/ Toggle Editing
Eilter...
Change Data Source...

Set Layer Scale Visibility...

Layer CRS »
Export b
Styles »

Add Layer Notes...

Databg

RiE
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Vector Layer Properties

(&) Layer Properties — TOLKIEN_BRG — Ini

Q

@ Information

‘{S\ Source
.ﬁ" Symbology
€3 Labels
€D Masks
." 3D View
Diagrams

E Fields

Attributes Form

Joins

ﬂ Auriliary Storage
C‘@ Actions

- Display
/ -
4 Rendering
e Temporal

Variables

i I Elevation

l Metadata
ﬂ Dependencies

Legend

QGIS Server

«€——————— Read-only summary of information and metadata on the current layer

Used to define general settings for the vector layer

Provides a comprehensive tool for rendering and symbolizing vector data

Provides the capabilities to configure smart labeling on vector layers

Helps configure the current layer symbols overlay with other symbol layers or labels
Provides settings for vector layers that should be depicted in the 3D Map view tool
Allows to add a graphic overlay to a vector layer

Provides information on fields related to the layer and helps organize them

Helps set up the form to display when creating new features or querying existing one
Allows to associate features of one layer to features from another loaded vector or table
Allows to store properties for layers that are not editable

Provides the ability to perform an action based on the attributes of a feature

Helps configure fields to use for feature identification

Allows to set the scale dependent visibility and simplify geometry

Provides options to control the rendering of the layer over time

Lists all the variables available at the layer’s level

Provides options to control the layer elevation properties within a 3D map view
Provides options to create and edit a metadata report on a layer

Allows to declare data dependencies between layers

Provides advanced settings for the Layers panel and/or the print layout legend

Consists of Description, Attribution, MetadataURL, and LegendUrl sections

Gives access to options that help to ensure the quality of digitized geometries

The (Vector) Layer Properties window provides information about the vector layer and provides general settings

to manage appearance of layer features in the map (symbology, labeling, diagrams) and interaction with the

mouse (actions, map tips, form design).
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Data Projections

(@ *Untitled Project — QGIS
Project Edit View Layer Settings Plugins Vector Raster Databs

NEERRY N-5-G-0
VS LLRPP M Q00348

Layers @
o il e T &3 AL

4 [ TOLKIEN BRG
D () Layer Properties — TOLKIEN_BRG — Source X

Zoom to Layer(s)

[Q W Settings
R

S Data source enceding | UTF-8 -
@ Source

T symbology

Zoom to Selection

o?, Show in Overview

Show Feature Count

@1 Show Labels ¥ Assigned Coordinate Reference System (CRS)

Copy Layer

EPSG:4326 - WGS B4 = %
€3 Labels
Reﬂame Layer S5 Changing this option does not modify the original data source or perform any reprojection of features. Rather, it can be used to
) override the layer's CRS within this project if it could not be detected or has been incorrectly detected.
L! Duplicate Layer €D Masks The Processing “Raprogect Layer” ool should be used to reproject features and permanently change a data source’s CRS,

[ Remove Layer...

Wy 3D View v
~ Open Attribute Table

b4
Diagrams Spatial Index Exists | | Update Extent
J/ Toggle Editing - * Bt =
Filter... ﬁ Flelds W Provider Feature Filter
Change Data Source... Attributes Form
Set Layer Scale Visibility... Joins
Layer CRS > .
24 ﬂ Auxiliary Storage
Export ’
e : B saen

o oy

& Rendering ] G
Query Builder

= Style - oK Cancel Apply Help

Add Layer Notes...

All vector/raster layers have a projection or Coordinate Reference System (CRS). The quickest way to check
projections is to right click on the layer > Properties... > Source tab.
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Raster Layer Properties

(G *Untitled Project — QGIS - Q Layer Properties - pop.¢

Project Edit View Layer Settings Plugins Vector Raster Database "-«‘ |

D& £a & ) - - V; ‘ @ Information ~€——Read-only summary of information and metadata on the current layer
OesreapPrPrPpL. ek . | o
. @ 0 A, \.‘_\\ Source Displays basic information about the selected raster

lezs e ¥ symbology Allows to control how the raster layer is rendered on map

o L@! 0_ ?' - - !

l_é Transparency Provides capabilities to set the transparency level of the raster layer

[ == srtm 61 10

Band 1 (Gray) »- Zoom to Layer(s)

e '8 Show in Qverview €3 abes Provides the capabilities to configure smart labeling on raster layer
Copy Layer
Rename Layer E Histogram Allows to view the distribution of the values in the raster
;1:!‘ Zoom to Native Resolution (100%)
- Stretch Using Current Extent 4 Rendering Allows to set scale dependent visibility and refresh layers at interval
D TOLKIEN Bl <3 Load Raster Attribute Table from VAT.DBF
L Duplicate Layer G Temporal Provides options to control the rendering of the layer over time
[l Remove Layer...
Move to Bottom BB Pyramids Allows to build pyramids to improve raster performance

Change Data Source... I . . . . et "
Set Layer Scale Visibiliy.. /M Elevation Provides options to control the layer elevation properties within a 3D map view

Layer CRS b -
Export y l Metadata Provides options to create and edit a metadata report on a layer

Styles ’
Add Layer Notes...

[ e |

Legend Provides advanced settings for the Layers panel and/or the print layout legend

, Display Helps to configure HTML map tips to use for pixel identification
E Attribute Tables Allows to convert symbology to and import an attribute table

=T QGIS Server Helps to configure settings of the data when published by QGIS Server

The (Raster) Layer Properties window provides information about the layer as well as the ability to set pyramids
levels, adjust appearance, and view the histogram.
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Layout Manager

(2 *Untitled Project — QGIS
Edit View Layer Settings Plugins Vector Rast

% New Ctrl+N =
N = % =

New from Template »

Open... Ctrl+0O \r

L Open From 'le®
Open Recent »

Close
B Save Ctrl+S - (—\_{ Search
3 Save As.. Ctrl+Shift+S

4 Layout Manager = O X

Save To »
Revert...

J/ Properties... Ctrl+Shift+P =
Show Duplicate Remove Rename
Snapping Options...
SnendiEns 5 w New from Template

1 _ New Print Layout... Ctrl+P Empty Layout = ‘  Create.. |

+) New Report...

ERCISES\EXERCISE_4\MAP_TEMPLATE\Exercise3_Portrait_Orientation.qp
Layout Manager... n -
= e ) Create Print Layout X

Open template directory
Layouts »

Models » Enter a unique print layout title
Close (a title wiill be automatically generated i left empty)

Exit QGIS Ctrl+Q

| OK Cancel Help

The Layout Manager allows you to create a new map layout either from an empty layout or a template. It can be
accessed from the Project menu (Project > Layout Manager...) or in the Print Layout window (Layout > Layout
Manager...).
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Print Layout

Q@ *New - (m] X
Layout Edit View [tems Mdhﬂu Settings

BROREDB L PRGERGe B¢l PANa&un

PLPANC DROEGE WE O

J....P....l....FQ...I....Ilqo...l....Iﬁ.‘o-..l....mo...l..Ho...l.. F”J llm . Undo History

Q, 3 items O e
p_—: ® @ Item
E . o T MAP TITLE z g -7 s
@ : Legerd v !-‘m

= é‘;:” : %Ilapinu
Eé;; u O ° @ 20m Om | Imm&s | Guides
= i nn:mm EES
p 1 \9)

?.:3 é w Main Properties v
T i reven
Q? ‘ Sde  swars =
P _E 5 - o Map rotation | 0.00 ° 2l €

® 8 GRS | usepoject RS -Jl@

¥ = V' Draw map canvas items -
1 item selected x:310.903mm  y:98.3503mm  page: 1 % |-|C

Print Layout interface: 1. Menu Bar; 2. Toolbar; 3. Map Layout; 4. ltems and Command History; 5. Layout
Properties; 6. Iltem Properties
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Layout Navigation Toolbar
Toolbar

RORER L e Rk

|/—\) (:'n |~- “ i
PPLPAR

e Zoomin
e Save project

e /00m out
e New layout

e Zoom to 100%
e Duplicate layout

e Zoom full
e layout manager

e Refresh view

e Add items from template

e Save as template

e Add Pages...

e Print Layout

e Export as image
e Export as SVG...

e Export as PDF...

e Undo

e Redo
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> Click on the Add Map button then draw a rectangle
for where the Map Canvas will appear.
(@ *Print Layout - o X
Layout Edit View [tems Addlitem Atlas Settings
B REREEB R oo @ ¢ -9 a%]
LPLAHS BB O QSE hHE
J|...P....|....Iso....n'u.llqo...l....lls.'o...l....F?O...l.”.F?O...l...!.P?O-.. Items  Undo History

@ = Items 2%
HEICE ® g [ltem
;? ] ] C v a I Map1
N
LE
[2 -
Ll -
) _: Layout = ItemProperties | Guides

8- ] O em Properties 2
= i =
(0| - v Main Properties =
LR % Update Preview
= (€2 Scale 429806 €
"h : Map rotation | 0.00 ® SR =8
/:)8_ B 0 r] s e 7

™ v Draw map canvas items
v = -
1 item selected X: 291,336 mm y: 100,554 mm page: 1 48.7% v e

13



~

MORU :: HEALTH @

. Tropical Health Network G EO LAB ’ @
Sl Asia Pacific Malaria
':-:"-?: APM E N | Elimination Network
Map Elements

This area keeps track of changes
Add map elements by clicking on the icons on

and allows you to customize map <
the toolbar or in the Add Item menu elements
l
Q *New - o X
Layout Edit View [t tlas  Settings
BRR D B RRee B e [P @R
PLAHARC BB LR EE E
Jy...P.H.ly..«F?...l...ylw.o”.l....Il?oum....qu..yl....Fs.o...l.”.PJ.O.I.. Items = Undo History
@ 3 ftems @y
'3 o ® gy [Item
2~ T - v r= <Picture> [}
u - B = - MAP TITLE v w= <Scalebar>
- - Legand v 8= Legend
W | o S v T) MAP TITLE
] e v £ Map 1
3 [P ——
[ | -
‘g 3
T 57" & d e @ 2in Layout = ItemProperbes = Guides
:-‘c B R Item Properties @®
3 Map1
! .
a ] w Main Properties
g -
R- Update Preview
“all :
A = Scale 546475 L =8
/? E = N - Map rotation | 0.00 © 2 E
‘o - RS Use project CRS v ||®
¥ _: vV Draw map canvas items v
1 item selected x: 310,903 mm y: 98,3803 mm page: 1 48.7% v b

Once the map has been added, the other map elements can be added. Their properties, as well as the page
properties, can be viewed and modified. The Print Layout tracks changes in the Undo History window.
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Layout

e Set the grid spacing and snap
tolerance

e Export settings

e Resize layout to content

Item Properties

e Set the font
e Set scale bar properties
e Set legend properties

e Set map element properties




