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Annex 3 - Creating a thematic map in QGIS 
 
This Annex describes the steps in creating a thematic map in QGIS Desktop version 3.0 
without using a map template. 
 

1. Open QGIS. 

2. Create a new map document by going to the main menu, click Project > New. 

3. Save your new map document by going to the main menu, click Project > Save or by 

clicking the Save button . 

4. The Choose a QGIS project file window opens. Browse to the location you want to 

save your map document in. 

5. Type in the name for your map document. Click Save.  

IMPORTANT NOTE: Remember to periodically save your map document as you go 
through the next steps. This ensures that your work is saved even if the GIS software 
or your computer suddenly crashes. 
 

6. In the main menu, go to Layer > Add Layer > Add Vector Layer or click the Add Vector 

Layer button  to add the prepared data to your map document. 

7. The Data Source Manager window opens. Browse to the location of your prepared 

data.  

 

 
8. Select the data you want to add then click Open. 
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You may add more than one data from the same folder by pressing the Control (ctrl) 
key on your keyboard while clicking on the data you need to add. 
 

9. Click Add. 

You will have to repeat steps 7 - 9 if your data are in different folders. 
 
Make sure to add both the geospatial data and attribute data. Ensure that both have 
a unique identifier for each object that would allow the attribute data to be joined to 
the geospatial data. 
 

10. Once all the needed data are added close the Data Source Manager window. 

11. To join a geospatial data to a table, right-click on the geospatial data, click Properties. 

12. The Layer Properties window opens. Click Joins from the left hand menu then click 

the plus sign  on the bottom left. 

13. The Add Vector Join window opens. Choose the layer to join (attribute data) and the 

join and target fields (fields containing the unique identifier). Click OK. 

 
 

14. Click Apply then OK in the Layer Properties window. 

15. You may add a basemap by going to Web > QuickMapServices in the main menu or 

by clicking the QuickMapServices button  in the Web toolbar. Select the 

appropriate basemap. 

This step will only work if you have installed the Quick Map Services plugin. If this is 

not the case, click Plugins > Manage and Install Plugins… in the main menu. The 
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Plugins window will open. In the Search field, type “QuickMapServices.” Once it 

appears, click it and click the Install plugin button on the lower right side. Wait for 

the plugin to install then close the plugin window. 

16. Decide on the appropriate mode of representation for your data. (In this example, 

the data will be presented as a choropleth map.) 

17. Symbolize your data by right-clicking on your geospatial layer then click Properties. 

18. The Layer Properties window opens. Click Symbology from the left hand menu. From 

the dropdown menu, choose how to show your data to correspond to your chosen 

mode of representation. Adjust the different parameters. Click OK.  

 
 

19. If you are not satisfied with how your data is symbolized, you may go back to the 

Symbology tab to adjust the symbology accordingly. 

20. Add labels to your map by right-clicking on the geospatial layer you would like to put 

a label on then click Properties. 

21. The Layer Properties window opens. Go to the Labels tab. From the dropdown list, 

choose Show labels for this layer. 
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22. In the Label with field, choose the field from the geospatial layer that you would like 

to serve as its label. Alternatively, you may choose to use an expression to label your 

data. 

 
 

23. Adjust the font type and size and other settings of the label to suit your map. Click 

OK. 

24. Once all the data are properly symbolized and labeled, proceed to creating the map 

layout. 

Note: The orientation of the map layout to be created should already be known at 

this point. 

25. Click Project > New Print Layout in the main menu. A small window will open asking 

you to create a unique title for your composer. If you do not enter a title, one will be 

generated automatically for you. Enter a title if you want. Click OK. The Layout 

window opens. 
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26. Visualize the placement of the other map elements. If it would help, sketch your 

planned layout on paper first. This would give you an idea of how all the map layout 

elements look together. 

27. To set the page size and orientation, right-click on the blank page and click Page 

Properties… The Page size section opens in the Item Properties tab on the lower right 

side of the window. Choose or set the page size and choose the orientation. 

 

28. To help align the elements, you can make the grid visible by clicking View in the main 

menu and activating Show Grid. 

29. To add your map to the composer, click the Add Map button  on the Toolbox 

toolbar. 

30. Click and drag the cursor on the page to delineate the area you want to position the 

map area at. 

31. In the Item Properties tab on the right side of the window, expand the Extents 

section then click on Set to map canvas extent. You will now see your symbolized 

data on the map. 
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32. Check that the focus of your map is in the center of the map area.  

a. If you just need to pan/move your map, use the Move item content button  

on the Toolbox toolbar.  

b. If you need to zoom in or out on the map, go back to the main QGIS window (the 

one where you symbolized your layers) and use the Zoom In or Zoom Out button 

on the Map Navigation toolbar. Then go back to the composer window and click 

Set to map canvas extent.  

Repeat these steps until you have centered your map. 

33. To add a border around your main map area, go to the Item Properties tab and scroll 

down to the Frame section. Check the box beside Frame. You may then change the 

frame color, thickness, and style as desired. 

 

34. To add the legend, click the Add Legend button  on the Toolbox toolbar. Click, 

hold, and drag your mouse to create a box in the location where you want the 

legend to appear. To change its position, click and drag it to the desired position. 
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35. To edit the legend, select the legend by clicking it in the map template or in the 

Items list. 

 

36. In the Items Properties tab, Legend items section, make sure that the Auto update 

button is unchecked. Doing this will allow you to edit the legend items. 

 

37. To move an item down or up on the list, click the item then use the Down or Up 

buttons   found below the list. 

38. If you need to remove a legend item, click the item then click the Minus button . 

39. If you need to add a legend item, click the Add button . Choose the layer you 

want to add from the list that appears then click OK. 

40. To rename a legend item, click it then click the Edit button  . Edit the name in 

the window that appears then click OK. 

41. You can edit the font of the legend items in the Fonts section by clicking on the 

correct group then selecting your desired font type, size, and style. 
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42. In the Columns section, you can specify if you need one or more columns for your 

legend items. 

 

43. In the Symbol section, you can change the width and height of the symbols in the 

legend. 
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44. If the legend box needs to be repositioned, click, hold, and drag it to the correct 

position. Or click it and use the arrow keys on your keyboard to move it to the 

correct position. 

45. To add a scale bar, click the Add Scale Bar button  on the Toolbox toolbar. Click, 

hold, and drag your mouse to create a box in the location where you want the 

legend to appear. To change its position, click and drag it to the desired position. 

46. To change the scale bar properties, click on the scale bar to select it. In the Item 

Properties tab, modify the style, units, segments, etc. 

 

47. To add a north arrow, click the Add Picture button  on the Toolbox toolbar. Click 

and drag the cursor where you want to position the north arrow. 

48. In the Item Properties tab, expand the Search directories section and wait for the 

image previews to load. Select the north arrow style you want. 
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49. To add border/box to position the title, click the dropdown menu on Add Shape 

button  on the Toolbox toolbar and choose Add Rectangle. 

50. Click and drag the cursor in the position you want to create the box/border. To resize 

the box, click and drag the tiny box at the corners and sides to the correct size. 

 

51. Repeat steps 49 to 50 to add the border/box for the other map elements (map 

production information, disclaimer, additional information, etc.). 

52. To add the title, click the Add Label button  on the Toolbox toolbar. Click the 

cursor inside the box. 

53. In the Item Properties tab, you can change the text in the Main properties section. 

You can change the font type and color, margin, and alignment in the Appearance 

section. 
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54. Repeat steps 52 to 53 to add the text for the other map elements (map production 

information, disclaimer, additional information, etc.) 

55. To add a logo, click the Add Picture button  on the Toolbox toolbar. Click and 

drag the cursor where you want to position the logo. 

56. In the Item Properties tab, expand the Main properties section and click the Browse 

button. The Select SVG or Image File window opens. Go to the folder where the logo 

image file is located, select the image, and click Open. Resize and reposition the logo 

if needed. 

 

57. If you are going to add an inset map to your map layout, first make sure that you are 

satisfied with how the main map area looks. Make the necessary changes if 

necessary. When done, click the main map area. 
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58. In the Item Properties tab, expand the Layers section. Check the Lock layers and Lock 

styles for layers item boxes. 

 

59. Go back to the main QGIS (the one where you symbolized your layers) window. Add 

and symbolize the data for the inset map by following the relevant steps in steps 6 to 

23 as necessary. 

60. Go back to the Composer window. Click the Add Map button  on the Toolbox 

toolbar. 

61. Click and drag the cursor on the page to delineate the area you want to position the 

inset map at. 

62. On the Item Properties tab on the right side of the window, expand the Extents 

section then click on Set to map canvas extent. You will now see your symbolized 

data on the inset map. 

63. Check that the focus of your inset map is in the center of the inset map area. 

a. If you just need to pan/move your map, use the Move item content  button 

on the Toolbox toolbar.  

b. If you need to zoom in or out on the map, go back to the main QGIS window  

and use the Zoom In or Zoom Out button on the Map Navigation toolbar. Then 

go back to the composer window and click Set to map canvas extent.  

Repeat these steps until you have centered your inset map. 

64. To add a border around your inset map, select your inset map, go to the Item 

Properties tab, and scroll down to the Frame section. Check the box beside Frame. 

You may then change the frame color, thickness, and style as desired. 
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65. Review your map layout and make sure that all elements are complete and the 

overall look is clean and balanced. 

66. Once you are satisfied with you map, click the Layout tab on the right side then 

expand the Export settings section. Make sure that the resolution is set to 300 dpi or 

higher. 

67. Click Layout in the main menu then choose to export your map as an image, PDF, or 

scalable vector graphics (SVG) file format.  

(Although keep in mind that when exporting to SVG, a message appears warning 
users of problems in saving in this format using QGIS.)  
 

68. Depending on the format you selected, the Save Layout as or Export to [format] 

window opens. Browse to the location you want to save your map layout in. 

69. Type in the file name for your final map layout. Click Save. 

You have now successfully created your own thematic map using QGIS. 
 

  


